Utama Pc & Mac Adakah Kes Emel Sensitif?

Adakah Kes Emel Sensitif?



Terdapat banyak kekeliruan mengenai sama ada alamat e-mel peka huruf besar kecil atau tidak. Ada yang mengatakan bahawa mereka, sementara yang lain menyatakan bahawa mereka tidak. Jadi, siapa yang betul? Dalam artikel ini, kita akan melihat sama ada alamat e-mel peka huruf besar kecil atau tidak peka huruf besar kecil.

Adakah Kes Emel Sensitif?

Apa yang Membuat Alamat E-mel?

Alamat e-mel terdiri daripada tiga bahagian - bahagian tempatan (juga dikenali sebagai nama pengguna), tanda @, dan bahagian domain. Setiap bahagian mempunyai peranannya sendiri dan tunduk pada peraturannya sendiri. Berikut adalah gambaran keseluruhan ringkas.

Menurut piawaian, bahagian lokal dari alamat e-mel boleh memuat hingga 64 aksara dan dapat terdiri dari sekumpulan karakter terbatas. Ini termasuk huruf abjad huruf besar dan kecil, angka dari 0 hingga 9, titik, dan watak khas. Watak khas termasuk `[dilindungi e-mel] # $% ^ & * () _- + = [] {} ~. Ia disambungkan ke bahagian domain dengan tanda @.

Bahagian domain boleh mencapai 255 aksara. Huruf ini boleh mengandungi huruf abjad Latin (huruf kecil dan besar), angka dari 0 hingga 9, dan tanda hubung. Kata hubung tidak dapat memulakan atau menamatkan bahagian domain.

Simbol antarabangsa juga boleh digunakan, walaupun lebih lanjut kemudian.

Adakah Kes Sensitif?

Jawapan yang betul untuk soalan ini adalah ya dan tidak. Menurut RFC 5321 , bahagian tempatan alamat e-mel peka huruf besar kecil. Ini bermaksud, secara teori, [dilindungi e-mel] tidak sama dengan [dilindungi e-mel]. Walau bagaimanapun, penyedia e-mel mempunyai kebebasan untuk memperlakukan bahagian-bahagian tempatan sebagai sensitif huruf besar dan tidak sensitif terhadap kes.

Contohnya, [dilindungi e-mel], [dilindungi e-mel], dan [dilindungi e-mel] secara teori adalah alamat e-mel yang berbeza. Sangat mudah untuk melihat bagaimana ini dapat menimbulkan masalah dan mengurangkan pengalaman pengguna jika pelayan e-mel memilih untuk memperlakukan bahagian-bahagian tempatan sebagai peka huruf besar kecil. Oleh itu, banyak pembekal menganggap bahagian tempatan dari alamat e-mel sebagai tidak sensitif terhadap kes.

bagaimana membuat teks berwarna dalam pertentangan

Bagi bahagian domain, RFC 1035 menetapkan bahawa perkara ini selalu tidak sensitif. Ini bermaksud bahawa anda boleh menulisnya dengan huruf kecil, huruf besar, atau gabungan keduanya dan e-mel anda akan berakhir di alamat yang sama. Dalam penggunaan praktikal, [dilindungi e-mel], [dilindungi e-mel], dan [dilindungi e-mel] adalah alamat e-mel yang sama.

Dalam latihan

Walaupun alamat e-mel sebahagiannya hanya sensitif huruf besar-kecil, pada amnya selamat untuk menganggapnya sebagai tidak sensitif huruf besar-kecil. Semua penyedia utama, seperti Gmail, Yahoo Mail, Hotmail, dan lain-lain, menganggap bahagian alamat e-mel tempatan sebagai tidak peka dengan huruf besar kecil. Walaupun begitu, anda harus memeriksa peraturan penyedia e-mel yang dengannya anda mahu membuat e-mel.

Mengikat titik sebelumnya, RFC 5321 yang disebutkan di atas mengesyorkan agar alamat e-mel baru dibuat dengan huruf kecil hanya untuk mengelakkan kekeliruan dan masalah penghantaran.

Sebaliknya, jika rakan atau rakan anda mempunyai alamat e-mel dengan gabungan huruf besar dan huruf kecil, disarankan untuk menulisnya seperti ketika anda menghantar e-mel kepada mereka. Kegagalan untuk melakukannya boleh menyebabkan e-mel tidak dihantar. Walau bagaimanapun, ini bukan masalah dengan penyedia e-mel utama seperti Gmail, Yahoo Mail, Hotmail, dan lain-lain.

Selain itu, Gmail juga tidak sensitif terhadap titik yang terdapat di bahagian tempatan e-mel ketika berkaitan dengan pengenalan akaun pengguna. Ini bermaksud bahawa jika akaun [dilindungi e-mel] ada, anda tidak akan dapat mendaftar [dilindungi e-mel] atau [dilindungi e-mel]

Pengantarabangsaan

Pada asalnya, alamat e-mel hanya dapat didaftarkan menggunakan huruf abjad Latin, angka, dan sekumpulan karakter khas ASCII yang terhad. Walau bagaimanapun IETF (Pasukan Petugas Kejuruteraan Internet) kemudiannya mengembangkan peraturan dan piawaian untuk memasukkan watak antarabangsa.

RFC6530 adalah yang pertama memasukkan dan mengatur penggunaan watak antarabangsa. RFC6531 diperluas berdasarkan peraturan dan piawaian. Selepas itu, peraturan dan piawaian diperbaharui melalui RFC6532 dan RFC6533 .

Anda kini boleh mendaftarkan alamat e-mel menggunakan pelbagai huruf, watak, dan skrip. Beberapa yang paling banyak digunakan termasuk aksara Latin dengan diakritik, abjad Yunani, watak Cina Tradisional, watak Jepun (hiragana, katakana, dan kanji), abjad Cyrillic, beberapa skrip India, dan juga sebilangan yang lain.

Penyertaan dan keserasian dengan alamat e-mel antarabangsa berbeza dari penyedia ke pembekal. Malah beberapa penyedia terbesar tidak sepenuhnya sesuai dengan alamat antarabangsa. Contohnya, Google membenarkan anda menghantar e-mel ke alamat antarabangsa tetapi tidak membenarkan anda membuat e-mel. Outlook 2016 mempunyai fungsi yang serupa.

Kesimpulannya

Tidak seperti bahagian nama domain, bahagian tempatan dari alamat e-mel peka huruf besar kecil. Oleh itu, banyak penyedia e-mel memilih untuk mengabaikan kepekaan kes bahagian tempatan untuk alasan praktikal dan mendorong orang untuk membuat e-mel dengan huruf kecil sahaja.

Artikel Yang Menarik

Pilihan Editor

iPhone XS Max – Cara Menyekat Mesej
iPhone XS Max – Cara Menyekat Mesej
Mendapatkan mesej rawak dari semasa ke semasa mungkin bukan masalah besar, kerana anda boleh memadamkannya dengan mudah. Walau bagaimanapun, jika seseorang menghantar spam peti masuk anda atau menghantar mesej yang tidak sesuai kepada anda, anda mungkin memutuskan untuk menyekat mereka. ini
Cara Mengaktifkan Penerbangan di Minecraft
Cara Mengaktifkan Penerbangan di Minecraft
Pemain Minecraft yang berpengalaman tahu bahawa terdapat beberapa cara untuk terbang dalam setiap mod. Tetapi melainkan jika anda mengetahui langkah yang tepat, penerbangan mungkin kelihatan terlalu rumit. Sekiranya anda ingin mengetahui cara mengaktifkan penerbangan di Minecraft, kami ada
Cegah Penyemak Imbas Edge Dari Menyimpan Data Kad Kredit
Cegah Penyemak Imbas Edge Dari Menyimpan Data Kad Kredit
Dengan Windows 10 versi 1809, penyemak imbas Edge mempunyai kemampuan untuk menyimpan maklumat kad kredit anda. Sekiranya anda mahu, anda boleh mematikan ciri ini.
Bagaimana untuk Menendang Seseorang dari Hulu
Bagaimana untuk Menendang Seseorang dari Hulu
Anda boleh menendang seseorang dari Hulu jika anda tidak lagi mahu berkongsi akaun anda atau kata laluan anda telah terjejas dengan mengalih keluar peranti mereka.
Cara Membuat Nada Dering untuk Peranti Android
Cara Membuat Nada Dering untuk Peranti Android
Hari ini, terdapat banyak alat percuma yang tersedia untuk mencipta nada dering tersuai menggunakan komputer atau peranti mudah alih. Nada dering unik bagus untuk hiburan dan ekspresi diri, serta membezakan antara pemanggil. Jika anda ingin membuat a
Enjin Carian Audio Terbaik
Enjin Carian Audio Terbaik
Alat carian audio untuk mencari sampel audio, klip bunyi, fail muzik penuh, buku audio, podcast, coretan berita dan banyak lagi.
Ulasan Microsoft Surface Go: Saingan Windows untuk Tab S4 dan iPad
Ulasan Microsoft Surface Go: Saingan Windows untuk Tab S4 dan iPad
Pilihan nama Microsoft untuk Surface Go adalah sesuatu yang ganjil. Go adalah akhiran pelik untuk melekat pada tablet. Lagipun, jika anda tidak dapat menggunakan tablet semasa dalam perjalanan, maka apa sebenarnya anda